Quantcast

[Bug 27563] New: Dungeons and Dragon Launcher fails with mono26 (works with dotnet11)

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 27563] New: Dungeons and Dragon Launcher fails with mono26 (works with dotnet11)

Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=27563

           Summary: Dungeons and Dragon Launcher fails with mono26 (works
                    with dotnet11)
           Product: Wine
           Version: 1.3.22
          Platform: x86
               URL: http://www.ddo.com/ddosupport/download-ddo
        OS/Version: Linux
            Status: NEW
          Keywords: download
          Severity: minor
          Priority: P2
         Component: mscoree
        AssignedTo: [hidden email]
        ReportedBy: [hidden email]


Created an attachment (id=35239)
 --> (http://bugs.winehq.org/attachment.cgi?id=35239)
terminal output

Crashes on start with mono26, saying:
System.NotImplementedException: COM/ActiveX support is not implemented

and a nice error dialog box. I'll attach terminal output with +text, so that
error is in it.

winetricks dotnet11 gets past that error, letting the launcher sorta work,
which then crashes in shdocvw, I think.

You don't need an account to test this, just get the client from:
http://www.ddo.com/ddosupport/download-ddo

(I used the high res version, though I doubt it matters).

--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 27563] Dungeons and Dragon Launcher fails with mono26 (works with dotnet11)

Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=27563

[hidden email] changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 27563] Dungeons and Dragon Launcher fails with mono26 (works with dotnet11)

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=27563

--- Comment #1 from Lee Forest <[hidden email]> 2012-07-05 11:02:44 CDT ---
Created attachment 40869
  --> http://bugs.winehq.org/attachment.cgi?id=40869
Error dialog capture.

The image I attached is the error dialog which is remedied by 'winetricks
dotnet11'. The client loads but crashes immediately after the clients interface
appears. The new error says "Failed to load resources from resource file.
Please check your setup" This occurred while using Wine 1.5.8.

--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 27563] Dungeons and Dragon Launcher fails with mono26 (works with dotnet11)

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=27563

--- Comment #2 from Austin English <[hidden email]> 2012-11-23 15:41:50 CST ---
*** Bug 32274 has been marked as a duplicate of this bug. ***

--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 27563] Dungeons and Dragons/Lord of the Rings online: launcher doesn't see COM/ActiveX as supported with builtin mono

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=27563

Austin English <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Summary|Dungeons and Dragon         |Dungeons and Dragons/Lord
                   |Launcher fails with mono26  |of the Rings online:
                   |(works with dotnet11)       |launcher doesn't see
                   |                            |COM/ActiveX as supported
                   |                            |with builtin mono

--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 27563] Dungeons and Dragons/Lord of the Rings online: launcher doesn't see COM/ActiveX as supported with builtin mono

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=27563

Alistair Leslie-Hughes <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 27563] Dungeons and Dragons/Lord of the Rings online: launcher doesn't see COM/ActiveX as supported with builtin mono

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=27563

--- Comment #3 from Alistair Leslie-Hughes <[hidden email]> 2013-08-20 19:45:09 CDT ---
Both DDO and LOTRO have changed to use a native QT launcher and no longer
require .NET.

--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 27563] Dungeons and Dragons/Lord of the Rings online: launcher doesn't see COM/ActiveX as supported with builtin mono

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=27563

Dan Kegel <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #4 from Dan Kegel <[hidden email]> 2013-08-21 05:42:54 CDT ---
I see the download button after signing up at ddo.com
now links to http://thehappycloud.com/ddo_en_installer
which downloads DDOProgressive_3.41.exe, interesting.  

Also, http://www.ddo.com/en/game/download still links to
http://content.turbine.com/sites/clientdl/ddo/ddostandard.exe
which still needs GC_DONT_GC=1.

Do both of these get you the qt version, then?

--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 27563] Dungeons and Dragons/Lord of the Rings online: launcher doesn't see COM/ActiveX as supported with builtin mono

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=27563

--- Comment #5 from Alistair Leslie-Hughes <[hidden email]> 2013-08-21 06:29:14 CDT ---
I usually copy it from my windows machine, so I dont know about the download
installer. However the Launcher failed without native .NET installed and now it
runs without .NET installed.

--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 27563] Dungeons and Dragons/Lord of the Rings online: launcher doesn't see COM/ActiveX as supported with builtin mono

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=27563

--- Comment #6 from Alistair Leslie-Hughes <[hidden email]> 2013-08-22 05:46:28 CDT ---
Fresh PREFIX.
GC_DONT_GC=1 wine ddostandard.exe

Wait for the Pando to download all needed files.
Ignore any errors that appear on the console.
Install DDO

Load the launcher

At this point, It gets stuck on "Initializing"
(I believe it's verifying files before it allows you to login).

--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 27563] Dungeons and Dragons/Lord of the Rings online: launcher doesn't see COM/ActiveX as supported with builtin mono

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=27563

--- Comment #7 from Alistair Leslie-Hughes <[hidden email]> 2013-08-22 07:09:15 CDT ---
After letting it sit there for awhile ~ 1h.  It updated to the latest version
and I was able to login.

Connecting to the server caused another issue, for another day.

--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Loading...