Quantcast

[Bug 3276] New: Failed to initialize video card - Initialisation of Graphics driver fails in W40K: Dawn of War.

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 3276] New: Failed to initialize video card - Initialisation of Graphics driver fails in W40K: Dawn of War.

Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=3276

           Summary: Failed to initialize video card - Initialisation of
                    Graphics driver fails in W40K: Dawn of War.
           Product: Wine
           Version: CVS
          Platform: PC
               URL: http://appdb.winehq.org/appview.php?appId=1918
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: P3
         Component: wine-directx
        AssignedTo: [hidden email]
        ReportedBy: [hidden email]


Wine gots in errors when trying to execute W40k: Dawn of War (application ID
1918). I have (poor) integrated graphics card: Intel(R) 82865G Graphics
Controller. But it is sufficient to play that game on Windows in this platform.
   On windows W40k.exe uses Software TnL, but on Wine I cant set it, so it tries
to use Hardware TnL, which propably leads to problems.

Here is "warnings.log" file from my setup
(last try 2005-09-02 11:21 is with Wine 20050830 CVS /
earlier try 21:10:41.1 was when running on same host with Windows 2000
Professional):
"
bash-2.05b$ less warnings.log
W40K started at 2005-09-02 11:21
OS NT 5.0, 484MB Physical Memory
RUN-OPTIONS
WORKING-DIR W:\Programs\THQ\Dawn of War
USER *************

11:21:47.5   MATHBOX -- Version=5, Cpu=INTEL Pentium-IV:f=15,m=2, Mode=SSE
11:21:47.5   GAME -- Warhammer, 1.00, Build 57117.44353
11:21:47.5   GAME -- Available memory: 483MB RAM, 483MB Pagefile
11:21:47.5   State::State - set socket send buffer to 221184
11:21:47.5   State::State - set socket receive buffer to 221184
11:21:47.5   HostState - 172.16.3.247:6112 / 172.16.3.247:6112
11:21:47.5   Session : Now Host
11:21:47.5   Session : We are now a Host
11:21:47.5   PeerState - 172.16.3.247:6112 / 172.16.3.247:6112
11:21:47.5   PeerState::ConnectCallbackHost - connecting to host at
255.255.255.255:6112
11:21:47.5   GSTransport::Connect - GT2AddressError
11:21:47.9   SPOOGE - Driver[Dx9 : Hardware TnL] on adapter[0], version[4,32]
11:21:47.9   SPOOGE - CheckDeviceType() failed!
11:21:47.9   SPOOGE - CheckDeviceType() failed!
11:21:47.9   GAME -- Failed to setmode in spooge
11:21:52.5   AppInitDevices -- Failed load for step: ''
11:21:52.5   APP -- The application failed to initialize it's devices, code: 2

Application closed with error code 2
21:10:40.3   SPDx9 -- Driver GUID = {D7B78E66-6632-11CF-84ED-496CA3C2CB35}
21:10:41.1   SPOOGE -- 68.00MB available texture memory
21:10:41.1   SPOOGE -- 68.00MB available texture memory
21:10:42.4   GAME -- Beginning FE
21:10:48.1   MOVIE -- Opening movie 'movies:relic_intro.lua'
21:10:52.5   SPOOGE -- 71.00MB available texture memory
21:10:53.2   SPOOGE -- 68.00MB available texture memory
21:10:54.7   MOVIE -- Closing movie 'movies:relic_intro.lua'
21:10:54.7   MOVIE -- Opening movie 'movies:dow_intro.lua'
21:10:55.6   MOVIE -- Closing movie 'movies:dow_intro.lua'
21:10:55.9   MOD -- (mod manager) W40k, 1.0
21:10:56.4   MOD -- (mod manager) Failed to load Folder
'W40k\Data_Shared_Textures\Full'
21:10:56.4   MOD -- (mod manager) Failed to load Folder 'W40k\Data_Sound\Low'
21:10:56.4   MOD -- (mod manager) Failed to load Folder 'W40k\Data_Whm\Low'
21:11:09.1   GAME -- Using player profile Arackhaen
21:11:38.5   GAME -- Ending FE
21:11:38.7   MOD -- (mod manager) shutting down
21:11:39.2   SPOOGE -- 68.00MB available texture memory
21:11:39.2   SPOOGE -- 68.00MB available texture memory
21:11:39.7   GAME -- Available memory: 494MB RAM, 1106MB Pagefile
21:11:39.7   HostState - 127.0.0.1:6112 / 127.0.0.1:6112
21:11:39.7   PeerState - 127.0.0.1:6112 / 127.0.0.1:6112
21:11:39.7   PeerState::ConnectCallbackHost - connecting to host at
255.255.255.255:6112
21:11:39.7   GSTransport::Connect - GT2AddressError
21:11:39.8   SPOOGE - Driver[Dx9 : Software TnL] on adapter[0], version[4,32]
21:11:39.9   SPDx9 -- Driver Name = ialmrnt5.dll  Device = \\.\DISPLAY1  Desc =
Intel(R) 82865G Graphics Controller
21:11:39.9   SPDx9 -- Driver Vendor = 0x8086  Device = 0x2572  SubSys =
0x4C438086  Rev = 0x0002
21:11:39.9   SPDx9 -- Driver Version  Product = 0x0006  Version = 0x000E
SubVersion = 0x000A  Build = 0x0EB2 (3762)
21:11:39.9   SPDx9 -- Driver GUID = {D7B78E66-6632-11CF-84ED-496CA3C2CB35}
21:11:39.9   SPOOGE -- 67.00MB available texture memory
21:11:39.9   SPOOGE -- 67.00MB available texture memory
21:11:40.1   GAME -- Beginning FE
21:11:41.7   MOD -- (mod manager) W40k, 1.0
".

After these, I tried to Execute GraphicsConfig.exe from DoW, it found "Direct3D
HAL" and use as plain version of settings as possible.

Then warnings.log output was:
"
12:13:23.0   MATHBOX -- Version=5, Cpu=INTEL Pentium-IV:f=15,m=2, Mode=SSE
12:13:23.0   GAME -- Warhammer, 1.00, Build 57117.44353
12:13:23.0   GAME -- Available memory: 483MB RAM, 483MB Pagefile
12:13:23.0   State::State - set socket send buffer to 221184
12:13:23.0   State::State - set socket receive buffer to 221184
12:13:23.0   HostState - 172.16.3.247:6112 / 172.16.3.247:6112
12:13:23.0   Session : Now Host
12:13:23.0   Session : We are now a Host
12:13:23.0   PeerState - 172.16.3.247:6112 / 172.16.3.247:6112
12:13:23.0   PeerState::ConnectCallbackHost - connecting to host at
255.255.255.255:6112
12:13:23.0   GSTransport::Connect - GT2AddressError
12:13:23.2   SPOOGE - Driver[Dx9 : Hardware TnL] on adapter[0], version[4,32]
12:13:23.3   SPOOGE - Windowed display does not support alpha channel (mode 21)!
12:13:23.3   SPOOGE - CheckDepthStencilMatch() failed( 75)!
12:13:23.3   SPOOGE - CheckDeviceType() failed!
12:13:23.3   GAME -- Failed to setmode in spooge
12:13:27.7   AppInitDevices -- Failed load for step: ''
12:13:27.7   APP -- The application failed to initialize it's devices, code: 2

Application closed with error code 2
".

It always ends up with "Failed to initialize video card" -dialog.

Should it work only, if I have a video card, mentioned in
"Drivers/spdx9_config.txt"?

--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.


Loading...