Quantcast

.net / mono problem in wine-1.7

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

.net / mono problem in wine-1.7

Beeblebrox
I am trying to get a third-party software working under wine (it also requires dotnet 35 or 40)
System: FreeBSD.9.2_amd64_wine-1.7.0,1_winetricks-20130707. In FreeBSD 64bit wine does not exist, so my wine is 32bit.  I have tried many things to get the software to work, but I run into problems each time. The first error I would like to get out of the way involves MONO. I have tried the software with MS .NET as well, but before moving on to that business, it would be better to see if I cen get it to work under MONO, or whether it is simply un-workable with MONO. Error code for the MONO setup implies insufficient .NET components on the system:

1. wine_XP + mono-0.0.8 + msxml3
fixme:actctx:parse_assembly_elem wrong namespace L"urn:schemas-microsoft-com:asm.v2"
fixme:actctx:parse_manifest_buffer failed to parse manifest L"C:\\path-to-file-name.exe.manifest"
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"appSettings" in state 1
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 3
....REPEATS....
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 3
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"system.web" in state 1
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"membership" in state 3
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"providers" in state 3
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 3
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"roleManager" in state 3
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"providers" in state 3
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 3
Missing method .ctor in assembly C:\path-to-file-name.exe, type System.Windows.Resources.AssemblyAssociatedContentFileAttribute
Can't find custom attr constructor image: C:\path-to-file-name.exe mtoken: 0x0a000006
Unhandled Exception:
System.IO.FileNotFoundException: Could not load file or assembly 'PresentationCore, Version=3.0.0.0, Culture=neutral, PublicKeyToken=#########' or one of its dependencies.
File name: 'PresentationCore, Version=3.0.0.0, Culture=neutral, PublicKeyToken=#########'
[ERROR] FATAL UNHANDLED EXCEPTION: System.IO.FileNotFoundException: Could not load file or assembly 'PresentationCore, Version=3.0.0.0, Culture=neutral, PublicKeyToken=#######' or one of its dependencies.
File name: 'PresentationCore, Version=3.0.0.0, Culture=neutral, PublicKeyToken=########'
Loading...